Back to overview
Network degradation
Apr 1, 2026 at 7:06pm UTC
Affected services
WTApi Backend
Resolved
Apr 1, 2026 at 7:06pm UTC
Due to network congestion, there may be delays in content delivery.
Affected services
Resolved
Apr 1, 2026 at 7:06pm UTC
Due to network congestion, there may be delays in content delivery.
Affected services